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ABSTRACT: 

Power BI has taken the world of business intelligence, data visualization and analytic s by storm. Power 

BI is an online service that enables searching data, transforming it, visualizing it, and sharing the 

developed reports and dashboards with other users in the same or different departments/organizations or 

even with the general public. As of February 2017, more than 200,000 organizations across 205 countries 

are using Power BI. Power BI is having a free option that has adequate features and functionality, it has 

become a serious contender for use as a business intelligence platform in small and medium organizations. 

One of the innovative features of Power BI is its Quick Insights feature (Michael Hart, 2017) that is built 

on a growing set of advanced analytical algorithms. After uploading a data set to Power BI, a click of a 

button can be used to invoke this feature that automatically builds many reports based on its analysis of 

the data, without any human intervention being required. This also helps reduce human errors in 

calculations and statistical techniques, which lead to un-verifiable research. Accepting 

even Excel spreadsheets as input, Power BI is easy to use and ripe for adoption as a platform for Research 

Data Analysis. In this paper, an attempt has been made to show how easily a data set of research data can 

be transformed by Power BI into a set of analytical reports and dashboards, and which can be shared with 

ease. 

Turn your data into a competitive advantage by using Power BI and Azure together to connect, combine, 

and analyze your entire data estate. Enable business analysts, IT professionals, and data scientists to 

collaborate seamlessly, providing a single version of data truth that delivers insights across your 

organization. "Now we have a single consolidated source of truth that everyone uses, and we can 

increasingly automate our analysis for a deeper dive into the intricacies of the data." 

 

INTRODUCTION : 

Power BI is an increasingly popular business intelligence and visualization tool from Microsoft that 

enables data analytic s and data visualization. Ron George initially designed Power BI in the summer of 

https://www.simplilearn.com/tutorials/power-bi-tutorial/what-is-power-bi
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2010. The initial release was available for public download the following year. Power BI Desktop, Power 

BI Service, Power BI Gateway, Power BI Report Server, and Power BI Mobile Apps are the key 

components of the platform. 

In this article, we’ll discuss the basics of Power BI Desktop and how to create a Power BI dashboard 

using Power BI Desktop. Then, we’ll publish this dashboard on Power BI Service. 

 

Power BI dashboards are single-page documents, often referred to as canvas, which illustrate a story 

through visualizations. A well-designed dashboard consists only of the highlights of a story. This is due to 

the fact that it is limited to one page. For more information, readers can view related reports. Power BI is 

the only service that offers dashboards. 

 

A single page visualization with multiple charts and graphs to tell a story is called a Power BI dashboard. 

This one-page visualization in a dashboard is also known as a Canvas. The Power BI dashboard is a 

feature only available in Power BI Service. Since a Power BI dashboard is limited to one page, it only 

contains the highlights of a story. You cannot create a dashboard on Power BI Desktop. 

RELATED WORK: 

The RELATED, as the name says, will return the corresponding value from one table to another. It is similar 

to the lookup value function in MS Excel, VLOOKUP.However, before we apply this DAX function in 

Power BI, we need to create a data model relationship between the tables we refer to.Below is the syntax of 

the RELATED DAX function in Power BI. 
We need to select the result column from the other table. It will fetch the details for us. If you are finding it 

difficult to understand this theoretical explanation, do not worry; below, we will give you practical 

examples in detail. 
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PROPOSED METHOD: 

 

0.1 Installing The Power Bi Desktop: Once the Power BI Desktop is downloaded, open the 

setup file and go to Next > I accept the terms in the License Agreement > Choose the destination 

folder > Create a desktop shortcut > Install 

>Launch Microsoft Power BI Desktop > Finish. 

Once installed, the Power BI home page will open up as follow 

 
 

0.2 Importing Data to Power BI: 
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The next step is to import data from any data source and visualize it in Power BI. To do so, press on 

Home > Get Data > Choose a data source > Connect as shown below. 
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0.3 Formatting the Data in Power Bi: 

Once you have imported your data,Power BI starts processing it and organic based on what it has 

found in the Navigator Window. Before loading the data, you have an option to format it. 

 

To do this, select the “Transform Data” available at the bottom of the page. In case you want to load the 

data without any formatting, click on “Load”. This is shown below. 
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When you select Transform data, a summarized form of the table is shown. This is shown below. 

 

 

 

 

0.4 Creating Visualizations for your Power BI Dashboards: 

Once you have imported your data completely onto Power BI, creating the visualization elements is 

very easy. You can incorporate different visualization elements (similar to the ones discussed in the previous 

section) by simply clicking on any Bar, Pie, or Donut chart or any other data visualization methods and types 

under the Visualizations tab on the right side of the panel as shown below 
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1.1 Power BI is a collection of apps, software services and connectors that come together to 

turn unrelated data into visually impressive and interactive insights. Power BI can work with 

simple data sources like Microsoft Excel and complicated ones like cloud-based or on-premises 

hybrid Data warehouses. Power BI has the capabilities to easily connect to your data sources, 

visualize and share and publish your findings with anyone and everyone. Power BI is simple 

and fast enough to connect to an Excel workbook or a local database. It can also be robust and 

enterprise-grade, ready for extensive modeling and real time analytics. This means it can be 

used in a variety of environments from a personal report and visualization tool to the analytics 

and decision engine behind group projects, divisions, or entire corporations. As Power BI is a 

Microsoft product and has built in connections to Excel, there are many functions that will be 

familiar to an Excel user. 

1.2 Parts of Power BI 

Power BI consists of a Microsoft Windows desktop application called Power BI Desktop, an online SaaS 

(Software as a Service) called Power BI Service and a mobile Power BI app that can be accessed from 

Windows phones and tablets, and also available on Apple iOS and Google Android devices. These three 

elements— Desktop, the Service, and Mobile apps - are the backbone of the Power BI system and lets users 

create,share and consume the actionable insights in the most effective way. 
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1.3 Use of Power BI and roles 
The use of Power BI could depend on the role that you are in. For example: if you are the stakeholder of a 

project, then you might want to use Power BI.Service or the Mobile app to have a glance at how the business 

is performing. But on the other hand, if you are a developer, you would be using Power BI Desktop 

extensively to publish Power BI desktop reports to the Power BI Service. In the upcoming modules we 

would be discussing these three components - Desktop, Service and Mobile apps - in more detail. 
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1.4 Power BI flow 

Generally, the flow starts at the Power BI Desktop, where a report is created. This created report can be 

published to the Power BI Service and finally shared so that the users can use it from the Mobile apps. This 

is the most common approach for sharing reports. There are other approaches but we will stick to this flow 

for this entire tutorial to help learn the different aspects of Power BI. 

 

 

 



European Journal of Molecular & Clinical Medicine 

 

ISSN 2515-8260         Volume 10, Issue 01, 2023 

 
 

5396 
 

1.5 Use Power BI 

The common flow of activity in Power BI looks like this: 1. Bring data into Power BI Desktop, and create a 

report. 2. Publish to the Power BI service, where you can create new visualizations or build dashboards. 3. 

Share dashboards with others, especially people who are on the go. 4. View and interact with shared 

dashboards and reports in Power BI Mobile apps. Depending on the user role, the user might spend most of 

the time in one of the three components than the other. 
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2.Importing Data set and Modeling 

Power BI can connect to a whole range of data sources from Excel sheets and local databases to several 

Cloud services. Currently, over 60 different cloud services have specific connectors to help you connect 

with generic sources through XML, CSV, text, and ODBC. Let us start connecting to one of the data 

sources. For today we will be working on the gap_minder_map.csv file. 

 

 

 

 

 

2.1 Importing data into Power BI Desktop 

Power BI Desktop has a Get Data button from the ribbon on the Home tab. In Power BI, there are all sorts of 

different data sources available. Select a source to establish a connection. Depending on your selection, you 

will be asked to find the source on your computer or network, or be prompted to sign in to a service to 

authenticate your request. As our first step to import the dataset/file into Power BI, we click on the Get 

Data icon on the ribbon of Home tab. 

          
 

 

 

 

 

 

 

 

 



European Journal of Molecular & Clinical Medicine 

 

ISSN 2515-8260         Volume 10, Issue 01, 2023 

 
 

5398 
 

3.Dealing with errors 

3.1 Checking for automatically detected errors 

Once queried, any detected errors will be displayed. Clicking on these errors will provide a brief description 

on what might have gone wrong. There will be some errors showing up in your data, click on the errors to 

see what has caused the issue. 2.2.2 Changing data type of column One of the most common errors is the 

detection of the datatype of a particular column. While loading the data, Power BI automatically assigns a 

column type based on the first lines of data. This can cause errors or other problems if the automated data 

type is not suited for that column. You may need to change data types of the columns to a relevant type for 

your data model. Any changes to the data needs to be done under the Data file listed under Other Queries. 

The life_exp column is displayed as text data. This is a problem as we may want to do numerical 

calculations with this data. We should change this to a numerical data type. • Select the gap-minder file. • 

Right click on top of the column and select Change type. • Change to Decimal Number. 

 
 

 

 

3.2 Changing data type of column: 

One of the most common errors is the detection of the datatype of a particular column. While loading the 

data, Power BI automatically assigns a column type based on the first lines of data. This can cause errors or 

other problems if the automated data type is not suited for that column. You may need to change data types 

of the columns to a relevant type for your data model. Any changes to the data needs to be done under the 

Data file listed under Other Queries. The life_exp column is displayed as text data. This is a problem as we 

may want to do numerical calculations with this data. We should change this to a numerical data type. 
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• Select the gap-minder file. 

 

• Right click on top of the column and select Change type. 

 

• Change to Decimal Number 

 

You can replace a current step in the query with Replace current step or add a new step to the query 

with Add new step. 

 

• Click Add new step. 

 

Once necessary changes are made, it is important to refresh and check if the change was applied. We 

can do this by clicking on the Refresh Preview button on the ribbon. You will notice that this has 

created errors due to several cells containing N/A. 
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      Plotting 

3.3  Visualization Panel 

We touched upon the different panels present in the Power BI interface. We will now explore the different 

panels dedicated to creating and formatting charts in detail. One of the panels is the 

Visualization panel highlighted in the Red box. It contains various types of charts that you can create to 

visualize your data. Some of the available chart types are - Stacked bar chart, Line chart, Area chart, Scatter 

plot, Pie chart, etc. You can also import a custom visual from a file or the marketplace if you click on the . . . 

icon. We will explore that in the later section. 
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4.Exporting and publishing report 

Now we want to create a report of our analysis and share it with others. We use Power BI to publish 

the report on the Power BI server. To do this, go to File > Publish > Publish to Power BI. 

 

 

 

 

 

After clicking on Publish to Power BI, you will be prompted to select a destination on the Power BI server 

where you want to publish your report. The default setting is My workspace. You can create different 

workspace dedicated to different projects on the server. Let’s use the default option, and click Select.It takes 

about 2-3 min to finalize the report and you will see the following success message on your screen. 

SUMMARY AND FUTURE WORK : 

The Art of Visualization – is a way of clarifying what it is you want to manifest in your life/business/, 

bringing it into clear, concise and sharp focus. Learn how to create stunning visualizations, improve your 

company's performance, and develop practical decision-making skills. The ever-increasing computational 

capacity has enabled us to acquire, process and analyze larger data-sets and information. However, the 

human memory and attention required to use this data is more limited and has remained relatively 

constant. 
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Data visualization can enable us to compress data and encode them in ways to aid perceptual, 

cognitive and emotional capacity required to comprehend, retain and make decisions using this 

data. Microsoft Power BI offers a suite of tools to analyze your data and extract business insights 

from it through building interactive dashboards. 

 

→ Power BI is a collection of processes, architectures, and technologies that transforms raw 

data into meaningful and informative content that helps to drive profitable business actions. 

 

 

→ It supports fact-based and logical decision-making by analyzing historical data rather than 

assumptions. 
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